Why am I encountering “String not found: <\ID 10120 >0x000000a1 …String not found: <\ID 10071 >”
Issue:
When device system fails to Autoboot, it results in displaying the following error “String not found: <\ID 10120 >0x000000a1 …String not found: <\ID 10071 >”
Product version affected:
SD 7.1 and up
Environment (OS/hardware/software):
Currently reported devices:
- Lenovo T460/T470/T480/T490/T560/T570/T580/T590
SED OPAL drives:
- 2.5 and 3.5 inch SED drives i.e.
- Micron M500, Seagate Thin Momentus SED
- Samsung Evo 840
- Seagate ST3000DM002-1BJ166 TCG Opal 3TB
- Intel Pro 2500 SED
OS Running:
- Any version of Windows 8/8.1/10 64 bits in which BIOS mode is set to UEFI
Profile setting:
- Profiles configured to use Permanent Autoboot
Probable Causes:
When using an SED drive, our v4 preboot does not support Opal disks when a device is configured under UEFI, in which the BIOS is configured to use Legacy and UEFI, with Legacy first (hybrid like setup in the bios). Having this type of BIOS configuration will result in SecureDoc installing the v4 boot logon with its UEFI preboot applications. Should UEFI be unable to boot, v4 can sometimes be used to boot a device.
Behavior Observed:
The following behavior is observed after completing the following steps successfully:
- SecureDoc installation completed successfully
- able to confirm that Boot Logon also successfully installed (can be verified as
well from userdata logs.)
- the encryption of the disk completed without issue
Upon restart of the device has completed, client observes that the following error is encountered upon loading SecureDoc preboot:
"String not found: <\ID 10120 >0x000000a1 …String not found: <\ID 10071 >"
Proposed Solution:
There are 3 possible solutions which may be considered depending on your situation with the device which are as follows:
Solution 1:
- Reboot the device
- At the BIOS Splash screen, press the F1 key in order to get into the BIOS of the affected Lenovo devices.
- From the Startup page, you will see UEFI/Legacy Boot will be set to either:
- Legacy Only or…
- Legacy and UEFI with Legacy First
- You will need to revise the setting to be changed to either:
- UEFI Only or…
- UEFI and Legacy with UEFI first
- Go to Restart Page and use Exit Saving changes
The system should now boot normally.
Solution 2:
In the event Solution 1 did not allow the system to boot normally, it’s possible that you may have encountered a BSOD event with error code showing “0xc000000f”. In this case, you will want to refer to the Manual UEFI Repair document to ensure that the SecureDoc Boot Logon is added correctly back into to the BIOS Boot Order.
Solution 3:
Should Solution 1 still not allow the system to boot, and you notices that you’re still encountering the same error with ‘string not found…’ error, then you will need to follow the procedure steps to deactivate the disk.
- Please refer to KB Article 1542 - How to Manage Hardware Encrypted Drive Using WinPE Tool.
Once you’ve followed the steps on deactivating the disk, you can then proceed with removing SecureDoc and reinstall. Please note that the settings previously described in Solution 1 will also still need to be applied. Once applied, then the installation will correctly update the boot order with the WinMagic Boot Logon.
Analysis:
There is a limitation when utilizing the older pre-boot (V4) on machines with legacy-BIOS and OPAL drives.
Limitation:
WinMagic will not provide support V4 Pre-Boot Authentication (PBA) for SEDs in favor of the fuller function, more capable, V5 Pre-Boot Linux (PBL). The existing V4 support for SEDs will remain in the product for the time being but will not be maintained or enhanced. Customers are recommended to migrate device encrypted with SED drives to use V5 PBL (As per SD-9411).