1025-BSOD after encryption on Dell Latitude E6520,E6420,Exx20 computers

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BSOD after encryption on Dell Latitude E6520/E6420/Exx20 computers

Symptom

A blank screen/system halt/BSOD appears after encryption on a Dell Latitude E6520 or E6420 or Exx20 series computer.

The operating system cannot be loaded.

Cause

This might be occurring because of a hardware driver incompatibility.

Resolution

Try to boot the device with the version 4 boot loader instead. You can do this by pressing the letter ‘a’ while the computer is booting. If this resolves the issue, the computer can be set to use the v4 boot loader via the SD Control Centre.

If this does not work, change the ATA hard drive mode to "AHCI"� in the BIOS. By default, this mode may be set to something different e.g., Mixed or Compatibility.

Note: With Windows XP the AHCI drivers are not included, so the resolution is more complex. The drive must be:

a)attached as a slave to another computer which has SecureDoc installed;

b)provided with the required key file;

c)decrypted;

d)have boot logon removed.

After these steps the AHCI drivers can be installed. You will need install the latest available Intel Rapid Storage utility from the device manufacturer’s website in order to install these drivers.

Custom Fields

  • Article ID: TS0220
  • Operating System: Windows