Issue:
SDConnex may produce the following error, “Service Error While Processing Request for….”

Symptom:
The SES server may hang or crashes.
Probable Causes:
The SES server may try to update a device that may have over a certain number of keyfiles (users) all at once and could potentially crash the Windows server.
Product version affected:
SES 5.3 and newer
Environment:
Windows 2008 R2 & SQL 2008 R2
Informational Gathering & Troubleshooting:
- Obtain the SDConnex detailed traced log.
- Please refer to KB 1593 How To Collect SDConnex and ADSync Logs
Resolution:
- Identify the device based on the IP address or by doing SQL queries on the specific device.
- Please refer to KB 1568 How to Run Search Queries on SQL Database
- Obtain the SD Connex Detailed traced log:
In this example of analyzing the detailed traced log, there is one computer Name = 'Computer xxxxxxx [Index:xxx has over 36 users assigned to it and it's trying update keyfiles for all of them at once. It will fail and try again - and keeps trying to generate 36 keyfiles all at once. This in turns will take a lot of resources from the server.

From the logs there one computer Name = 'Computer 1135782 [Index:738 has like 36 users assigned to it and it's trying update keyfiles for all of them at once. It fail and try again - and generate 36 keyfiles - it's take a lot of resources at once. IP 172.18.229.6 Computer name = Computer 4113747
Internal Reference:
- SD-4394
- SF-57763
- CAS-14064-T7N2R5